プラスα空間

ブログ in お市 のーと

FreeBSD 10.0でpkg upgradeの後にエラー

いまだに、FreeBSD 10.0を使っています。データをバックアップしてからの、OSのアップデートが面倒で。パッケージをアップグレードしようとしたら、エラーになって、先に進まなくなりました。

[フリーイラスト] 赤い悪魔の格好をした外国人女性

root@freebsd:~ # pkg upgrade
Updating FreeBSD repository catalogue...
Fetching meta.txz: 100%    944 B   0.9kB/s    00:01    
Fetching packagesite.txz: 100%    6 MiB   2.0MB/s    00:03    
Processing entries: 100%
FreeBSD repository update completed. 26006 packages processed.
New version of pkg detected; it needs to be installed first.
The following 1 package(s) will be affected (of 0 checked):

Installed packages to be UPGRADED:
	pkg: 1.8.7_1 -> 1.9.4_1

Number of packages to be upgraded: 1

2 MiB to be downloaded.

Proceed with this action? [y/N]: y
Fetching pkg-1.9.4_1.txz: 100%    2 MiB   1.3MB/s    00:02    
Checking integrity... done (0 conflicting)
[1/1] Upgrading pkg from 1.8.7_1 to 1.9.4_1...
[1/1] Extracting pkg-1.9.4_1: 100%
/lib/libc.so.7: version FBSD_1.4 required by /usr/local/lib/libpkg.so.3 not found
root@freebsd:~ # pkg upgrade
/lib/libc.so.7: version FBSD_1.4 required by /usr/local/lib/libpkg.so.3 not found

検索したら、同じ状況になっている人がいました。

原因は、FreeBSD 10.0が古すぎるからとの事です。2015年2月にサポートが切れてますから。残念! 切腹!

コメントを残す

INSERT IGNORE INTO `ra_title` (url, title, logtype, created_on, updated_on) VALUES ('https://oichinote.com/plus/2017/02/error-after-pkg-upgrade-on-freebsd-10-0.html', 'FreeBSD 10.0でpkg upgradeの後にエラー | プラスα空間', '0', NOW(), NOW()) :