プラスα空間

ブログ in お市 のーと

仕方なくPHP5.6に戻しました

本ウェブサイト高速化のために、PHPのバージョンを7.1にしました。

PHPのバージョンを7.1にしました

うまく行っている様に思えましたが、iOSのWordPress appを使っての、投稿の下書き保存ができません。調べてみると、JetpackはPHP7.1に対応していないことがわかりました。

PHP7.1にするとJetpackのせいでiOSのWordPressアプリと同期できない

この調査をしていて、WordPressのプラグインで、PHPのバージョンの互換性を確認できることがわかりました。ご紹介ありがとうございます。

このプラグインをインストールすると、ツールPHP Compatibilityが使える様になります。PHP 7.0に設定して、互換性チェックをしてみました。その結果、いくつかのプラグインが、PHP7.0に対応していないことがわかりました。その中には、自作のテーマ、プラグインも含まれます。

PHP7非対応

Google XML Sitemaps with Multisite Supportが対応してないのって、なんなの!?

ダメじゃん…。テーマが対応してないのは、困るなぁ。仕方なく、PHPバージョンを5.6に戻しました。

コメントを残す